rvmによるrubyのアップデートでハマる

Rails3のいい本があったので早速購入。
rvmというのがあってrubyの複数バージョンを保存&切り替えが出来るというので入れてみた。(入れ方はネットにもある http://net.tutsplus.com/tutorials/ruby/how-to-install-ruby-on-a-mac/ これとか)
その入れるので先ずつまずく
1)bash << (curl・・・ が動かない
どうも文法が変わったらしく

こうじゃないとダメっぽい。

なんとか入れた所で次のエラー

2) rvm install 1.9.3がうごかない
エラーとしてはXcode4.2と関係があるらしい( http://kuroigamen.com/55 )
ちなみに rvm install 1.9.2 –with-gcc=clang
でいけるというのも試したけど
You requested building with ‘clang’ but it is not in your path.
っていうエラー(^^;;;
しょうがないからGCCを入れた。入れたらコマンドでvi ~/.bashうんたらって打って
export文書いて rvm install1.9.3を実行。そしてエラーw
rvm install 1.9.2に下げて実行したらできた(TT
最後に rvm use 1.9.2をして
ruby -vで確認。

[Rails]
「Railsはどのバージョンだろ」と思って押したrails -vが

/Library/Ruby/Site/1.8/rubygems/dependency.rb:247:in `to_specs’: Could not find rails (>= 0) amongst [bundler-1.1.1, bundler-1.1.1, rake-0.9.2] (Gem::LoadError)
from /Library/Ruby/Site/1.8/rubygems/dependency.rb:256:in `to_spec’
from /Library/Ruby/Site/1.8/rubygems.rb:1210:in `gem’
from /usr/bin/rails:18

というエラーを吐いてきた。どうも今まで入っていたRailsが使えないっぽい新しく入れないと
gem env
でこのgemがRuby 1.9.2のものであるのを確認(gemはrubyに入っているもの)
sudo gem install rails
でインストール(^^

試しに古いプロジェクトを起動しようと思って
rails s
ってやったらエラった。どうもプロジェクトに入ってた設定というか bundle installで入っているものが足りないらしい。
まぁバージョンアップしたから当たり前だよね。
とりあえず古いプロジェクトフォルダで
bundle install
その後
rails s
で localhost:3000で動作確認!やったね!

コメントを残す